Kens Cobra vers. 2.0

mooreken
Posts: 424
Joined: Sat May 09, 2015 12:25 pm

Kens Cobra vers. 2.0

Post by mooreken »

I'll be doing a running tab on my rebuilding of my Cobra. As I had mentioned the real work will not start until June. Along with the motor the tow trucks hook came off and snatched the front lower section of the nose and tried to rip it off. So there will be body (fiberglass) repairs along with paint. This will also give me a chance to repair the "oil cooler area" that I broke hitting a parking lot parking curb on one of my first DSCC cruises.

But here is the start of the blog....I had ordered a new Tremec TKX and it has showed up. I just had to show it off.
IMG_2146.jpg
IMG_2146.jpg (126.15 KiB) Viewed 885 times

Ken
Attachments
IMG_2145.jpg
IMG_2145.jpg (130.03 KiB) Viewed 885 times
Tom Wells
Posts: 711
Joined: Fri May 08, 2015 7:34 pm
Contact:

Re: Kens Cobra vers. 2.0

Post by Tom Wells »

Ken,

A lovely sight :!:

Didn't realize you had body damage too - sorry 'bout that.

Keep us posted.

Tom
BlackSnake
Posts: 199
Joined: Mon Jul 13, 2015 4:09 am

Re: Kens Cobra vers. 2.0

Post by BlackSnake »

Subscribed... :cool:
mooreken
Posts: 424
Joined: Sat May 09, 2015 12:25 pm

Re: Kens Cobra vers. 2.0

Post by mooreken »

I got the Cobra out of the trailer and on the lift today...

Here is a bit of video with a few laps and a windup with the car on the lift.....
The data is about 6 seconds ahead of the video. I still need more practice with Harry’s Lap Timer. Lol

https://youtu.be/E7knn0mwU5o
Last edited by mooreken on Sat May 29, 2021 9:05 pm, edited 2 times in total.
Tom Wells
Posts: 711
Joined: Fri May 08, 2015 7:34 pm
Contact:

Re: Kens Cobra vers. 2.0

Post by Tom Wells »

Ken,

OUCH!

Tom
BlackSnake
Posts: 199
Joined: Mon Jul 13, 2015 4:09 am

Re: Kens Cobra vers. 2.0

Post by BlackSnake »

OUCH x2
mooreken
Posts: 424
Joined: Sat May 09, 2015 12:25 pm

Re: Kens Cobra vers. 2.0

Post by mooreken »

What is wrong with this picture. Hint below.
1E5FC7FB-EBAA-4A4C-89CE-C221F1070D1B.jpeg
1E5FC7FB-EBAA-4A4C-89CE-C221F1070D1B.jpeg (135.24 KiB) Viewed 674 times
Hint


Hint



Hint


Hint
Make the picture bigger, it wasn’t a rod that broke.
Tom Wells
Posts: 711
Joined: Fri May 08, 2015 7:34 pm
Contact:

Re: Kens Cobra vers. 2.0

Post by Tom Wells »

Ken,

I haven't seen that many engine failures but...

It looks as if that main cap needed six or eight bolts? Wonder what got it?

Maybe it just needed to be forged?

Tom
mooreken
Posts: 424
Joined: Sat May 09, 2015 12:25 pm

Re: Kens Cobra vers. 2.0

Post by mooreken »

Yep it’s my first main cap failure. It’s just one of those things. I used that type of block in my racing car and never had an issue. But obviously it can happen.
I feel good that is wasn’t anything that I did other than making too much power in a block that was never designed to handle 500hp.
Tom Wells
Posts: 711
Joined: Fri May 08, 2015 7:34 pm
Contact:

Re: Kens Cobra vers. 2.0

Post by Tom Wells »

Ken,

No good deed goes unpunished :shock:

Tom
Post Reply